Stream: Mirror: Isabelle Development Mailing List

Topic: [isabelle-dev] Isabelle/jEdit won't start today


view this post on Zulip Email Gateway (Jul 14 2020 at 13:23):

From: Jasmin Blanchette <j.c.blanchette@vu.nl>
Dear all,

Today I pulled Isabelle (08f1e4cb735f), wrote "isabelle jedit -l Pure Sledgehammer.thy" (from "src/HOL"), then got the Isabelle splash screen for some time (10 to 60 s), then sudden exit. I tried building Pure first, updating back to some changeset from last week which used to work, reboot: all to no avail. It's not the first time I run into such an issue, I think. How does one go around to debug this, given the opacity of the splash screen? And is there a workaround (I would be really keen on doing some Sledgehammer development today actually...).

Jasmin


isabelle-dev mailing list
isabelle-dev@in.tum.de
https://mailman46.in.tum.de/mailman/listinfo/isabelle-dev

view this post on Zulip Email Gateway (Jul 14 2020 at 13:27):

From: Tobias Nipkow <nipkow@in.tum.de>
I had a similar problem once and it had to do with my external monitor.
Unpluggig it helped. But your issue seems to be different.

Tobias
smime.p7s

view this post on Zulip Email Gateway (Jul 14 2020 at 13:29):

From: Jasmin Blanchette <j.c.blanchette@vu.nl>
It's the same issue, actually. Once I saw I had the same problem with Isabelle2020, and I recalled all the crash I used to have when teaching Concrete Semantics due to the beamer, I thought about the monitor -- about one minute before you wrote. Thanks anyway. :)

Jasmin


isabelle-dev mailing list
isabelle-dev@in.tum.de
https://mailman46.in.tum.de/mailman/listinfo/isabelle-dev


Last updated: Mar 04 2024 at 12:30 UTC